Announcement

Please be advised we have relocated our status page over to Digicert Status Page. Please bookmark the new page as we plan to decommision this page in the coming weeks.

DigiCert Website Security Alert - Connectivity to DigiCert services unreachable
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted Oct 16, 2020 - 23:35 UTC
Monitoring
Services have been restored and we are monitoring the results.
Posted Oct 16, 2020 - 22:09 UTC
Investigating
We are currently experiencing a technical problem with our DigiCert Services system and are working to resolve the issue as quickly as possible.

We are tracking this issue under Case# 02262313

While we work to restore access to our DigiCert Services, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted Oct 16, 2020 - 22:01 UTC
This incident affected: Managed PKI (User Authentication) (MPKI8, MPKI7, CI+ platform), Partners (SOAP API, REST API (Encryption Everywhere), Developer Portal, Partner Portal, End User Portal), Enterprise (Managed PKI For SSL Console, API VICE2, CWS - Complete Website Security Console, CIC - Certificate Intelligence Center, SAS - Secure App Service, API - Secure App Service, WAF/DDOS), and Symantec Trust Center, Light Enterprise.