DigiCert Website Security Alert - SSL & Code Signing Buy Flows & DigiCert Trust Center Login
Incident Report for Digicert Website Security
Resolved
This incident is now resolved, please clear your browser cache for the latest changes to propagate (CTRL+F5)
Posted Mar 05, 2020 - 07:50 UTC
Investigating
We are currently experiencing a technical problem with our SSL & Code Signing Buy Flows & Login pages and are working to resolve the issue as quickly as possible.

DigiCert Trust Center Login:
https://trustcenter.websecurity.digicert.com/process/trust/console_login?

Buy and Renewal links for all products on the our eCommerce site are currently unavailable from the main page, please use the links below to procure certificate until the issue has been rectified.

Secure Site:
https://trustcenter.websecurity.digicert.com/process/trust/productOptions?productType=SecureSite&application_locale=VRSN_US&validityYears=1&sanCount=0&numServers=1&inid=brhome_ssl_ss_buy
Secure Site with EV:
https://trustcenter.websecurity.digicert.com/process/trust/productOptions?productType=SecureSiteEV&application_locale=VRSN_US&validityYears=1&sanCount=0&numServers=1&inid=brhome_ssl_ssev_buy
Secure Site Pro:
https://trustcenter.websecurity.digicert.com/process/trust/productOptions?productType=SecureSitePro&application_locale=VRSN_US&validityYears=1&sanCount=0&numServers=1&inid=brhome_ssl_ssp_buy
Secure Site Pro with EV:
https://trustcenter.websecurity.digicert.com/process/trust/productOptions?productType=SecureSiteEVPro&application_locale=VRSN_US&validityYears=1&sanCount=0&numServers=1&inid=brhome_ssl_sspev_buy
Multi-Subdomain Secure Site Wildcard:
https://trustcenter.websecurity.digicert.com/process/trust/productOptions?productType=SecureSiteWC&application_locale=VRSN_US&validityYears=1&sanCount=0&numServers=1&inid=brhome_ssl_sswc_buy

Extended Validation Code Signing:
https://trustcenter.websecurity.digicert.com/process/trust/productOptions?productType=EVCodeSigning&flavor=MSAuthentiCode&application_locale=VRSN_US&newLanguage=en&inid=brhome_cs_ev_buy
Microsoft Authenticode:
https://trustcenter.websecurity.digicert.com/process/trust/productOptions?productType=SoftwareValidationClass3&flavor=MSAuthentiCode&application_locale=VRSN_US&newLanguage=en&inid=brhome_cs_ma_buy
Java:
https://trustcenter.websecurity.digicert.com/process/trust/productOptions?productType=SoftwareValidationClass3&flavor=JavaSoftDev&application_locale=VRSN_US&newLanguage=en&inid=brhome_cs_java_buy
Microsoft Office and VBA:
https://trustcenter.websecurity.digicert.com/process/trust/productOptions?productType=SoftwareValidationClass3&flavor=VBADevCert&application_locale=VRSN_US&newLanguage=en&inid=brhome_cs_movba_buy
Adobe AIR:
https://trustcenter.websecurity.digicert.com/process/trust/productOptions?productType=SoftwareValidationClass3&flavor=AdobeAIRDev&application_locale=VRSN_US&newLanguage=en&inid=brhome_cs_air_buy

We are tracking this issue under Case# 01869560

While we work to restore access to our SSL & Code Signing Buy Flows, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted Mar 05, 2020 - 06:39 UTC
This incident affected: Symantec Trust Center.