DigiCert Website Security Alert - Support and Validation Chat Portal
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted Feb 17, 2020 - 11:04 UTC
Investigating
We are currently experiencing a technical problem with our Support and Validation Chat Portal system and are working to resolve the issue as quickly as possible.

Currently our chat portal is offline due to Salesforce experiencing degrading performance with their system. You can read more about it here - https://status.salesforce.com/

We are tracking this issue under Case# 01831463

While we work to restore access to our Chat Portal, you can contact us through:

Telephone: Call us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted Feb 16, 2020 - 14:39 UTC