DigiCert Website Security Alert - Retail Certificate Management Platform
Incident Report for Digicert Website Security
Resolved
This incident has been resolved. We apologize for any inconvenience this may have caused.
Posted 3 months ago. Jun 05, 2019 - 20:38 UTC
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Jun 05, 2019 - 18:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Jun 05, 2019 - 17:51 UTC
Identified
We are currently experiencing a technical problem with our Retail Certificate Management Platform and are working to resolve the issue as quickly as possible.

After logging in successfully to your Trust Center account the certificate information is blank. Also the SAN option is unavailable when going through the enrollment process.

We are tracking this issue under Case# 01341344

While we work to restore access to our Retail Certificate Management Platform, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted 3 months ago. Jun 05, 2019 - 12:23 UTC
This incident affected: Symantec Trust Center.