DigiCert Website Security Alert - Partner Platform Certificate Life-cycle Operations
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 10, 2019 - 01:56 UTC
Investigating
We are currently experiencing a technical problem with our Partner Platform system and are working to resolve the issue as quickly as possible.

The issue has an impact on all certificate life cycle operations [enroll, renew, replace]

We are tracking this issue under Case# 01236949

While we work to restore access to our Partner Platform, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted 5 months ago. Apr 10, 2019 - 00:43 UTC
This incident affected: Partners (SOAP API, Partner Portal, End User Portal).