Announcement

Please be advised we have relocated our status page over to Digicert Status Page. Please bookmark the new page as we plan to decommision this page in the coming weeks.

DigiCert Website Security Alert - Validation System
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted May 14, 2020 - 04:05 UTC
Investigating
We are currently experiencing a technical problem with our Validation system and are working to resolve the issue as quickly as possible.

We are tracking this issue under Case# 02005599

While we work to restore access to our Validation System, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted May 14, 2020 - 01:59 UTC