Announcement

Please be advised we have relocated our status page over to Digicert Status Page. Please bookmark the new page as we plan to decommision this page in the coming weeks.

DigiCert Website Security Alert - Telephony System
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 20:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2020 - 17:45 UTC
Investigating
DigiCert Website Security Alert - Telephony System

We are currently experiencing a technical problem with our Telephony system and are working to resolve the issue as quickly as possible.

You may experience a delay when calling into our Support and Validation Center

In the mean time please contact us via chat and email:

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted Mar 23, 2020 - 14:00 UTC