DigiCert Website Security Alert - Light Enterprise Certificate Management Platform
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted Jan 08, 2020 - 18:33 UTC
Investigating
We are currently experiencing a technical problem with our Certificate Management Portals and are working to resolve the issue as quickly as possible.

We are tracking this issue under Case# 01760496

While we work to restore access to our Symantec, Thawte and Geotrust Light Enterprise Portals, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted Jan 08, 2020 - 17:32 UTC
This incident affected: Light Enterprise.