DigiCert PKI Alert - Certificate Lifecycle Intermittent Issues
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted Feb 12, 2020 - 15:19 UTC
Investigating
We are currently experiencing an intermittent technical problem with our Certificate Lifecycle system and are working to resolve the issue as quickly as possible.

We are tracking this issue under Case# 01822605

While we work to restore access to our Certificate Lifecycle system, you can contact us through:

Telephone: Call us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert PKI Support
Posted Feb 11, 2020 - 19:01 UTC
This incident affected: Managed PKI (User Authentication) (MPKI8, MPKI7).