Announcement

Please be advised we have relocated our status page over to Digicert Status Page. Please bookmark the new page as we plan to decommision this page in the coming weeks.

DigiCert Website Security Alert - Domain Management
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted Mar 31, 2020 - 14:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2020 - 19:27 UTC
Investigating
We are currently experiencing a technical problem with our Domain Management system and are working to resolve the issue as quickly as possible.

While we work to restore access to our , you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted Mar 30, 2020 - 17:09 UTC
This incident affected: Enterprise (Managed PKI For SSL Console, CWS - Complete Website Security Console), Symantec Trust Center, Light Enterprise, and Partners (Partner Portal, End User Portal).