DigiCert Website Security Alert - Order notification emails not being delivered
Incident Report for Digicert Website Security
Resolved
MSSL email notification service has been restored
Posted 2 months ago. Jun 25, 2019 - 21:43 UTC
Investigating
We are currently experiencing a technical problem with our MSSL Order Email Notifications system and are working to resolve the issue as quickly as possible.

Order notification emails are not being delivered [Confirmation, Approval, Rejection & Revocation Email]

We are tracking this issue under Case# 01378397

While we work to restore access to our MSSL Order Email Notifications, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted 2 months ago. Jun 25, 2019 - 07:14 UTC
This incident affected: Enterprise (Managed PKI For SSL Console, API VICE2).