DigiCert Website Security Alert - MSSL Portal - Digicert.com Redirect
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted 23 days ago. Aug 23, 2019 - 13:05 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 30 days ago. Aug 16, 2019 - 21:19 UTC
Investigating
We are currently experiencing a technical problem with our MSSL Prod and Pilot Portal system and are working to resolve the issue as quickly as possible.

Currently all traffic hitting our MSSL pilot and Production portals are being redirected to the digicert.com URL. We are currently working on a fix and tracking the issue under case #01478460

While we work to restore access to our MSSL portals, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted 30 days ago. Aug 16, 2019 - 16:04 UTC
This incident affected: Enterprise (Managed PKI For SSL Console).