Announcement

Please be advised we have relocated our status page over to Digicert Status Page. Please bookmark the new page as we plan to decommision this page in the coming weeks.

DigiCert Website Security Alert - Gatekeeper
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted Jun 19, 2020 - 08:40 UTC
Identified
We are currently experiencing a technical problem with our Gatekeeper Services system and are working to resolve the issue as quickly as possible.

All Gatekeeper lifecycle operations (enrolment, replacement, renewals) are affected by this outage.

While we work to restore access to our Gatekeeper services, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted Jun 19, 2020 - 07:07 UTC
This incident affected: Gatekeeper.