DigiCert Website Security Alert - Certificate Management & Lifecycle
Incident Report for Digicert Website Security
Resolved
issue is now resolved
Posted 6 months ago. Apr 23, 2019 - 04:33 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 6 months ago. Apr 23, 2019 - 03:10 UTC
Investigating
We are currently experiencing a technical problem with our Certificate Management & Lifecycle system and are working to resolve the issue as quickly as possible.

Certificate Management & Lifecycle operations (enrolment, renewal, replace) are currently affected.

We are tracking this issue under Case# 01259960

While we work to restore access to our Certificate Management & Lifecycle, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted 6 months ago. Apr 23, 2019 - 03:10 UTC
This incident affected: Partners (SOAP API, REST API (Encryption Everywhere), Partner Portal, End User Portal) and Symantec Trust Center, Light Enterprise.