Intermittent Timestamp Service Errors
Incident Report for Digicert Website Security
Resolved
The issue is now resolved
Posted 4 months ago. Jun 13, 2019 - 01:10 UTC
Investigating
We are currently investigating intermittent errors when accessing our timestamping servers.
Posted 4 months ago. Jun 12, 2019 - 22:37 UTC
This incident affected: Code Signing Timestamp Service.