DigiCert Website Security Alert - Partner Order Enrollment Issues
Incident Report for Digicert Website Security
Resolved
The issue has now been resolved.
Posted Jun 28, 2019 - 06:48 UTC
Identified
issue has been identified and engineering team is working with priority to resolve.
Posted Jun 28, 2019 - 02:55 UTC
Investigating
We are currently experiencing a technical problem with our Partner Order Enrollments system and are working to resolve the issue as quickly as possible.

The issue is impacting certificate lifecycle functionality through the partner channel (enrollments, renewals, replacements and revocations).

We are tracking this issue under Case# 01385930

While we work to restore access to our Partner order enrollments, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted Jun 28, 2019 - 01:13 UTC
This incident affected: Partners (SOAP API, REST API (Encryption Everywhere), Partner Portal, End User Portal).