Announcement

Please be advised we have relocated our status page over to Digicert Status Page. Please bookmark the new page as we plan to decommision this page in the coming weeks.

DigiCert PKI Alert - MPKI 8 Portal
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted Sep 23, 2020 - 07:57 UTC
Identified
We are currently experiencing a technical problem with our MPKI 8 portal and are working to resolve the issue as quickly as possible.

We are tracking this issue under Case# 02225991

While we work to restore access to our MPKI 8 portal, you can contact us through:

Telephone: Call us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert PKI Support
Posted Sep 23, 2020 - 00:02 UTC
This incident affected: Managed PKI (User Authentication) (MPKI8).