Click Here For Digicert System Status
DigiCert Website Security Alert - RapidSSL & GeoTrust 2YR Renewals
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted Feb 24, 2020 - 05:35 UTC
Update
A fix is being planned by end of business this Friday (21-Feb) US time.
Posted Feb 20, 2020 - 07:22 UTC
Identified
We are currently experiencing a technical issue with our RapidSSL & GeoTrust 2 Year Renewals system and are working to resolve the issue as quickly as possible.

We are currently experiencing issues with RapidSSL & GeoTrust 2 Year renewal orders, the orders cannot be processed at this time. Please consider 1 year term at this time.

We are tracking this issue under Case# 01836739

You can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted Feb 20, 2020 - 03:04 UTC
This incident affected: Partners (SOAP API, Partner Portal).