Announcement

Please be advised we have relocated our status page over to Digicert Status Page. Please bookmark the new page as we plan to decommision this page in the coming weeks.

DigiCert Website Security Alert - Connectivity to digicert services unreachable from some countries
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted Aug 30, 2020 - 17:46 UTC
Monitoring
Our provider has implemented a fix and we have seen recovery on this issue. We continue to monitor this and will update this page accordingly if the situation changes.
Posted Aug 30, 2020 - 15:50 UTC
Update
Our provider continues to work on a resolution to this issue. We are in contact with them and will share and update once available.
Posted Aug 30, 2020 - 15:04 UTC
Identified
DigiCert Website Security Alert - Connectivity to digicert services unreachable from some countries

We are currently experiencing a technical problem with our connectivity to digicert services from some countries and are working to resolve the issue as quickly as possible.

We are tracking this issue under Case# 02184514

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Aug 30, 2020 - 11:38 UTC
This incident affected: Partners (SOAP API, REST API (Encryption Everywhere), Developer Portal, Partner Portal, End User Portal) and Enterprise (Managed PKI For SSL Console, API VICE2, CWS - Complete Website Security Console, CIC - Certificate Intelligence Center, SAS - Secure App Service, API - Secure App Service, WAF/DDOS).