Announcement

Please be advised we have relocated our status page over to Digicert Status Page. Please bookmark the new page as we plan to decommision this page in the coming weeks.

DigiCert Website Security Alert - MSSL certificate lifecycle and approvals
Incident Report for Digicert Website Security
Resolved
This incident has been resolved.
Posted Nov 02, 2020 - 23:18 UTC
Identified
We are currently experiencing a technical problem with our MSSL certificate lifecycle and approvals system and are working to resolve the issue as quickly as possible.

Error 4837 is encountered during MSSL certificate lifecycle (enrol,reissue,renewal and approvals) impacting certificate issuance.

We are tracking this issue under Case# 02289374

While we work to restore access to our systems, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted Nov 02, 2020 - 23:11 UTC
This incident affected: Enterprise (Managed PKI For SSL Console, API VICE2).