DigiCert Website Security Alert - Delays in processing of orders
Incident Report for Digicert Website Security
Resolved
This issue has been resolved.
Posted 3 months ago. Jul 11, 2019 - 21:32 UTC
Investigating
We are currently experiencing a technical problem with our Order Processing system and are working to resolve the issue as quickly as possible.

We are experiencing technical difficulty with our order processing system which may impact the issuance or processing of certificate orders.

We are tracking this issue under Case# 01415010

While we work to restore access to our Order Processing, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted 3 months ago. Jul 11, 2019 - 09:19 UTC
This incident affected: Enterprise (Managed PKI For SSL Console), Partners (Partner Portal, End User Portal), and Symantec Trust Center, Light Enterprise.